Niveaux de qualité des packages d'applications YunoHost

Afin de faciliter le packaging d'applications par des étapes successives à atteindre, chaque package est affublé d'un niveau de qualité, de 0 à 10.
Un package doit satisfaire un certain nombre de critères pour atteindre chaque niveau. De plus pour atteindre un niveau, le package doit avoir préalablement atteint le niveau précédent.

Ce classement des applications par niveaux présente 3 avantages: - Le packaging d'application est d'autant plus ludique, avec des objectifs clairs à atteindre et des étapes successives. - Une application correctement packagée est davantage mise en avant qu'une application ne respectant pas les règles de packaging. - Les utilisateurs peuvent rapidement voir le niveau d'une application et ainsi savoir si le package est de bonne qualité.

Résumé des niveaux

Niveau 0
L'application ne fonctionne pas.

Niveau 1
L'application s'installe et se désinstalle correctement dans certains cas.

Niveau 2
L'application s'installe et se désinstalle correctement dans toutes les configurations communes.

Niveau 3
L'application peut être mise à jour.

Niveau 4
L'application peut-être sauvegardée et restaurée.

Niveau 5
Le code du package d'application respecte certaines règles de syntaxe.

Niveau 6
Le package d'application est dans l'organisation YunoHost-Apps.

Niveau 7
Le package d'application passe avec succès l'ensemble des tests d'intégrité.

Niveau 8
Le package d'application respecte toute les recommendations de packaging d'apps. C'est une app de très bonne qualité.

Niveau 9
Le package d'application respecte des recommandations de packaging supérieures. Non disponible pour le moment.

Niveau 10
Le package d'application est jugé parfait !

Les niveaux de qualité en détails:

Niveau 0

L'application ne s'installe pas ou ne fonctionne pas après installation.
C'est le niveau le plus bas, une application de niveau 0 est considérée comme non fonctionnelle.

YEP à respecter pour atteindre le niveau 0: - YEP 1.1 : Nommer son app et son dépôt - YEP 1.2 : Inscrire l'app sur un "répertoire" connu

Niveau 1

L'application s'installe et se désinstalle correctement.
Mais des exceptions sont possibles, si au moins une méthode d'installation est fonctionnelle ainsi que sa suppression alors l'application est considérée comme fonctionnelle.

YEP à respecter pour atteindre le niveau 1: - YEP 2.2 : Utiliser bash pour les scripts principaux - YEP 2.5 : Copier correctement des fichiers - YEP 2.7 : Donner des permissions suffisantes aux instructions bash - YEP 2.15 : Suivre les instructions d'installation de l'application

Niveau 2

L'application s'installe et se désinstalle dans toutes les configurations communes.

Si une application ne permet pas certaines configurations d'installation, celles-ci doivent être indiquées clairement dans le readme du package. Toutefois, le niveau 2 ne peut pas être atteint si une configuration d'installation est volontairement écartée sans raison valable.
Cela n'empêche pas de restreindre volontairement les installations publiques, privées ou multi-instance si l'application le justifie.

YEP à respecter pour atteindre le niveau 2: - YEP 1.5 : Mettre à jour régulièrement le statut de l'app - YEP 2.18.2 : Supporter l'installation sur un domaine - YEP 2.18.3 : Supporter l'installation sur un sous-domaine - YEP 2.18.4 : Supporter l'installation sur un sous-dossier - YEP 4.6 : Gère le multi-instance

Niveau 3

L'application supporte l'upgrade depuis une ancienne version du package.
L'application doit pouvoir être mise à jour depuis une version précédente du package sans provoquer d'erreur.

YEP à respecter pour atteindre le niveau 3: - YEP 2.3 : Sauvegarder les réponses lors de l'installation

Niveau 4

L'application peut-être sauvegardée et restaurée sans erreur sur la même machine ou une autre.

YEP à respecter pour atteindre le niveau 4: - YEP 4.3 : Fournir un script de sauvegarde YunoHost fonctionnel - YEP 4.4 : Fournir un script de restauration YunoHost fonctionnel

Niveau 5

L'application ne présente aucune erreur dans Package linter.
Il peux y avoir des faux positifs dans Package linter. Ces situations seront gérées au cas par cas.

YEP à respecter pour atteindre le niveau 5: - YEP 1.3 : Indiquer la licence associée au paquet - YEP 2.1 : Respecter le format du manifeste - YEP 2.12 : Utiliser les commandes pratiques (helpers) - YEP 2.18.1 : Lancer le script d'installation d'une webapp correctement

Niveau 6

Le package d'application est dans l'organisation YunoHost-Apps.

YEP à respecter pour atteindre le niveau 6: - YEP 1.4 : Informer sur l'intention de maintenir un paquet - YEP 1.6 : Se tenir informé sur l'évolution du packaging d'apps - YEP 1.7 : Ajouter l'app à l'organisation YunoHost-Apps - YEP 1.8 : Publier des demandes de test - YEP 1.9 : Documenter l'app - YEP 1.10 : Garder un historique de version propre - YEP 2.9 : Enlever toutes traces de l'app lors de la suppression - YEP 3.3 : Faciliter le contrôle de l'intégrité des sources - YEP 3.5 : Suivre les recommandations de la documentation de l'app - YEP 3.6 : Mettre à jour les versions contenant des CVE

Niveau 7

L'application ne présente aucune erreur dans Package check.
En considérant le maximum de tests possibles pour l'application.

YEP à respecter pour atteindre le niveau 7: - YEP 2.4 : Détecter et gérer les erreurs - YEP 2.6 : Annuler l'action si les valeurs d'entrées sont incorrectes - YEP 2.8 : Modifier correctement une configuration système - YEP 2.10 : Configurer les logs de l'application - YEP 2.11 : Utiliser une variable plutôt que l'app id directement - YEP 2.13 : Traduire le package en anglais - YEP 3.2 : Ouvrir un port correctement

Niveau 8

Le package d'application respecte toute les recommandations de packaging d'apps. C'est une app de très bonne qualité.

YEP à respecter pour atteindre le niveau 8: - YEP 2.16 : Vérifier la disponibilité des dépendances sur ARM, x86 et x64 - YEP 2.18.5 : Ajouter la tuile YunoHost pour naviguer facilement entre les applications - YEP 4.1 : Lier au ldap - YEP 4.2 : Lier l'authentification au sso - YEP 4.5 : Utiliser les hooks

Si une application n'est pas disponible sur une architecture, et qu'il est impossible de contourner cette limitation raisonnablement, cette limitation doit être indiquée dans le readme et prise en compte dans le script d'installation. L'installation de l'application sur une architecture non supportée doit être stoppée avant de modifier les fichiers.

Niveau 9

L'application respecte toutes les YEP optionnelles.

YEP à respecter pour atteindre le niveau 9: - YEP 2.14 : Remplir correctement un fichier de conf - YEP 2.17 : Prendre en compte la version d'origine lors des mises à jour - YEP 3.4 : Isoler l'app - YEP 4.2.1 : Déconnexion

Niveau 10

L'application est jugée parfaite !
Ce niveau ultime pour une application ne peux être atteint que suite à étude approfondie du package et par la validation du groupe Apps.